CloudFlare down

Incident Report for Coinmetro

Resolved

This incident has been resolved.
Posted Dec 05, 2025 - 09:13 UTC

Update

We are continuing to work on a fix for this issue.
Posted Dec 05, 2025 - 09:03 UTC

Identified

Due to a global outage on Cloudflare’s side, Coinmetro may be unavailable for some users, and certain services may be intermittent.
We’re working closely with our partners to restore full access as soon as possible.
We’ll update this thread immediately once services are back to normal. Thanks for your patience
Posted Dec 05, 2025 - 09:03 UTC
This incident affected: Website.